const regex = /\[(\d+\/\d+\/\d+),\s+(\d+:\d+:\d+\s+[a|p]m)\]\s(\w.+):\s(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\d+\\\/\\d+\\\/\\d+),\\s+(\\d+:\\d+:\\d+\\s+[a|p]m)\\]\\s(\\w.+):\\s(.+)', 'gm')
const str = `[6/8/18, 7:40:41 pm] Kanu Tandon: Oye hoye! DP to Dekho zara`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}