const regex = /^ *((#\d+)|((box|bin)[-. \/\\]?\d+)|(.*p[ \.]? ?(o|0)[-. \/\\]? *-?((box|bin)|b|(#|num)?\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\d+)|(p *-?\/?(o)? *-?box)|post office (box|bin)|((box|bin)|b) *(number|num|#)? *\d+|(num|number|#) *\d+)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ *((#\\d+)|((box|bin)[-. \\\/\\\\]?\\d+)|(.*p[ \\.]? ?(o|0)[-. \\\/\\\\]? *-?((box|bin)|b|(#|num)?\\d+))|(p(ost)? *(o(ff(ice)?)?)? *((box|bin)|b)? *\\d+)|(p *-?\\\/?(o)? *-?box)|post office (box|bin)|((box|bin)|b) *(number|num|#)? *\\d+|(num|number|#) *\\d+)', 'igm')
const str = `Valid:
P. O. Box : Valid
P.O.Box : Valid
Post Box : Valid
Post Office Box : Valid
P.O.B : Valid
P.O.B. : Valid
POB : Valid
Post Office Bin : Valid
100,, P O Box Des Moines : Valid
P O Box DesMoines1000 : Valid
P O Box Des Moines 1000 : Valid
Post Office Box : Valid
Post Office Box : Valid
Post Box 123 : Valid
PO
P.O.
P.B.
Invalid:
POTTER STREET", "Campbell Dr.
Post Office : Invalid
Box : Invalid
Bin : Invalid
Post : Invalid
Postal Code : Invalid
Portsmouth
Campbell
Raspberry
Polonium
Polar beer.
12 Box
HC73 P.O. Box 217
P O Box 125
P. O. Box
P.O. Box 123
P.O. Box
p-o box
Po Box
POBOX123
p box
Post Box 123
Post Office Box 123
Post Office Box
Box 123
Box-122
Box122
box #123
box 122
box 123
P.O.B 123
P.O.B. 123
P.O.B.
POB 123
POB
Post 123
P.O 123
The Postal Road
Box Hill
123 Some Street
Controller's Office
pollo St.
123 box canyon rd
777 Post Oak Blvd
123 box `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}