using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"catid=([0-9]+)";
string input = @"meine-domian.de/index.php?option=com_content&view=article&id=3045:artikel-alias&catid=396&Itemid=223&lang=de";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}