$re = '/(^|&)catid=396(&|$)/';
$str = 'option=com_content&view=article&id=3045:artikel-alias&catid=396&Itemid=223&lang=de';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);