using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]\w+(?=(?:[^\""]*\""[^\""]*\"")*[^\""]*$)";
string input = @"Match1
Match2(Match3(""NoMatch a NoMatch blabla""), Match4)
meh<Match5>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}