using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""(?P<dest_ip>[^""]+)"",""(?P<dest_port>[^""]+)"",""(?P<uri>[^""]+)"",""(?P<request>[^""][^,]+)"",""(?P<response>[^\n]+)""$";
string input = @"""192.0.0.20"",""80"",""fl=city,name,code,group=true&group.field=city"",""GET /solr/""lpbm""/select?fl=city"",""Logging rate limit reached""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}