re = /\b[A-Z0-9._%+-]+(?:@|[(\[]at[\])])[A-Z0-9.-]+\.[A-Z]{2,6}\b/mi
str = 'abc@gmail.com
abc(at)gmail.com
abc[at]gmail.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end