$re = '/^(?:.(?!custom|onetomany|manytomany|atom|tomcat|tomorrow|automatic))*?(tom).*/m';
$str = 'foo bar test
another tom test
but wait, automatic
but wait, tomorrow
but wait, atom tom ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);