package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[ls](.*?)\[\/ls]`)
var str = `[ls]Something[/ls]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}