re = /\^(?=[A-Z .()\/-]{1,24}\^)[A-Z .()-]+\/[A-Z .()-]+\^/m
str = '^TEST/TEST^
^TEST TEST^
^TEST/TE/ST^
^TEST/TE+ST^
^^
^/^
^/A^
^A/^
^//^
^A/A^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end