#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[^\n]+\n)+)"
Local $sString = "NOMEAR ISABELLE FERREIRA ZARONI, ID FUNCIONAL Nº" & @CRLF & _
"5100796-7, para exercer, com validade a contar de 16 de novembro" & @CRLF & _
"de 2020, o cargo em comissão de Assessor, símbolo DAS-7, da Sub-" & @CRLF & _
"secretaria de Concessões e Parcerias, da Secretaria de Estado de" & @CRLF & _
"Planejamento e Gestão, anteriormente ocupado por Vinicius dos San-" & @CRLF & _
"tos Silva, ID Funcional n° 5108029-0. Processo nº SEI-" & @CRLF & _
"1 2 0 0 0 1 / 0 1 4 6 11 / 2 0 2 0 ." & @CRLF & _
"" & @CRLF & _
"NOMEAR KARINE MATOS DIAS, ID FUNCIONAL Nº 5092869-4 para" & @CRLF & _
"exercer, com validade a contar de 16 de novembro de 2020, o cargo" & @CRLF & _
"em comissão de Assessor, símbolo DAS-7, da Secretaria de Estado" & @CRLF & _
"de Planejamento e Gestão, anteriormente ocupado por Amauri Ferrei-" & @CRLF & _
"ra do Carmo, ID Funcional nº 5099579-0. Processo nº SEI-" & @CRLF & _
"1 2 0 0 0 1 / 0 1 4 6 11 / 2 0 2 0 ." & @CRLF & _
"" & @CRLF & _
"NOMEAR ROSIONE FERNANDES DE SÁ, ID FUNCIONAL Nº" & @CRLF & _
"4413710-9, para exercer, com validade a contar de 16 de novembro" & @CRLF & _
"de 2020, o cargo em comissão de Assistente II, símbolo DAI-6, da" & @CRLF & _
"Secretaria de Estado de Planejamento e Gestão, anteriormente ocu-" & @CRLF & _
"pado por Luis Henrique Ferreira de Aquino, ID Funcional nº 1914315-" & @CRLF & _
"0. Processo nº SEI-120001/014825/2020." & @CRLF & _
"" & @CRLF & _
"EXONERAR, com validade a contar de 16 de novembro de 2020," & @CRLF & _
"LUIS HENRIQUE FERREIRA DE AQUINO, ID FUNCIONAL Nº" & @CRLF & _
"1914315-0, do cargo em comissão de Assistente II, símbolo DAI-6, da" & @CRLF & _
"Secretaria de Estado de Planejamento e Gestão. Processo nº SEI-" & @CRLF & _
"120001/014825/2020." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")