$re = '/(?<=<key>).*(?=<.key>)/m';
$str = '<key>asdhli;dfiusldhfsdjcjklsdhckjsdhc/shu/sdhv/ 8798798707;</key>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);