$re = '/^(?=.*?\d)(?=.*?[a-z]).*/m';
$str = 'a1saasa
1saasa
sssssss
111111
saqsas1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);