$re = '/^(?P<demo1>[A-Za-z]+)(?:(?:,\s*)|(?:\s+))(?P<demo2>[A-Za-z]+)/m';
$str = 'abc, def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);