$re = '/((?:(?:https?):\/\/)?(?:regex101\.com|www\.regex101\.com|regex101\.com|(?<![:\/])\/)[-a-z0-9+&@#\/%?=~_|!:,.;]*[-a-z0-9+&@#\/%=~_|])/';
$str = '"https://regex101.com/toto
"http://regex101.com/toto
"regex101.com/toto
"/toto/dsqdqs
"http://toto';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);