re = /(^(?:[A-Z]{2}-\d{2}-\d{2})|(?:\d{2}-[A-Z]{2}-\d{2})|(?:\d{2}-\d{2}-[A-Z]{2})$)/m
str = '00-00-AA
AA-00-00
00-AA-00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end