using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+?[^\.]+(?!\.)";
string input = @"bla bla 17a aber nicht 17. bla
und hier auchnoch 1a aber nicht 1. blabla";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}