$re = '/(?<=href=).*(?=>)/';
$str = '<a rel="prettyPhoto[gallery-113]" href=\'http://www.bundoransurfco.com/wp-content/uploads/2014/11/11149460_10152656389992000_7842452340110509403_n.jpg\'>]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);