$re = '/\d+(?:[ ,.]\d+)*/m';
$str = '233.43 USD
634,233 EURO
2300 000 USD
430 000 EU';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);