$re = '/(\d\D*?){10}/m';
$str = '.1d23..345.6789.
1234567890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);