const regex = /(?i)\b([\w]{3}(?=[\w]*;))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\b([\\w]{3}(?=[\\w]*;))', 'mg')
const str = `d;dd;abc;def;ghi;jkl;ff,sd;cv;s;asdfasdf;s;asdf;asdfasdfad;trhegdas;sd;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}