$re = '/(Total \|\|)(.*?)(\\\\\\\\n)/';
$str = ' Total || xxxxxxxxxxxxxxxxxxx \\\\n|}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);