import Foundation
let pattern = #"(?s).*(<p><span class='label'>Rating<\/span>: <div class='metadata' id='rating'>(.*?)<\/div><p>).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p><span class='label'>Adapter_Classes</span>: <div class='metadata list' id='adapter_classes'><ul>
<li>ArchiveOfOurOwnOrgAdapter</li>
</ul></div><p>
<p><span class='label'>AO3 Categories</span>: <div class='metadata list' id='ao3categories'><ul>
<li>Gen</li>
</ul></div><p>
<p><span class='label'>Author</span>: <div class='metadata list' id='author'><ul>
<li>ofwyrmsandguns</li>
</ul></div><p>
<p><span class='label'>Authorhtml</span>: <div class='metadata' id='authorHTML'><a class='authorlink' href='https://archiveofourown.org/users/ofwyrmsandguns/pseuds/ofwyrmsandguns'>ofwyrmsandguns</a></div><p>
<p><span class='label'>Author ID</span>: <div class='metadata list' id='authorId'><ul>
<li>ofwyrmsandguns</li>
</ul></div><p>
<p><span class='label'>Author URL</span>: <div class='metadata list' id='authorUrl'><ul>
<li>https://archiveofourown.org/users/ofwyrmsandguns/pseuds/ofwyrmsandguns</li>
</ul></div><p>
<p><span class='label'>Bookmarks</span>: <div class='metadata' id='bookmarks'>1</div><p>
<p><span class='label'>Byline</span>: <div class='metadata' id='byline'>ofwyrmsandguns</div><p>
<p><span class='label'>Chapters/Total Chapters</span>: <div class='metadata' id='chapterslashtotal'>5/?</div><p>
<p><span class='label'>Characters</span>: <div class='metadata list' id='characters'><ul>
<li>Talen-Jei (Elder Scrolls)</li>
<li>Original Characters</li>
</ul></div><p>
<p><span class='label'>Cover_Image</span>: <div class='metadata' id='cover_image'>old</div><p>
<p><span class='label'>Packaged</span>: <div class='metadata datetime' id='dateCreated'>2023-02-14T16:45:24.226001</div><p>
<p><span class='label'>Published</span>: <div class='metadata datetime' id='datePublished'>2023-01-25T00:00:00</div><p>
<p><span class='label'>Updated</span>: <div class='metadata datetime' id='dateUpdated'>2023-02-14T00:00:00</div><p>
<p><span class='label'>Summary</span>: <div class='metadata' id='description'><div class="userstuff">
<p>In 4E 201, Talen-Jei, a bartender in Riften, somehow sells a drink that references on ex-black hand from the Dark Brotherhood. Wherever this drink got it's name, it can't be a coincidence that the drink with nightshade has the link to the Dark Brotherhood. Where did he get the name from? What was he doing in Gideon's bar, other than making drinks?</p><p>(AKA: A backstory for Talen-Jei before he came to Riften, and his work as a Shadowscale before going renegade, and the order dissolving.)</p>
</div></div><p>
<p><span class='label'>Extra Tags</span>: <div class='metadata list' id='extratags'><ul>
<li>FanFiction</li>
</ul></div><p>
<p><span class='label'>Fandoms</span>: <div class='metadata list' id='fandoms'><ul>
<li>Elder Scrolls V: Skyrim</li>
</ul></div><p>
<p><span class='label'>File Extension</span>: <div class='metadata' id='formatext'>.epub</div><p>
<p><span class='label'>File Format</span>: <div class='metadata' id='formatname'>epub</div><p>
<p><span class='label'>Freeform Tags</span>: <div class='metadata list' id='freeformtags'><ul>
<li>Shadowscales</li>
<li>Original Character(s)</li>
<li>character backstory</li>
<li>Implied/Referenced Alcohol Abuse/Alcoholism</li>
<li>Alcohol</li>
<li>Minor Character Death</li>
</ul></div><p>
<p><span class='label'>Hits</span>: <div class='metadata' id='hits'>23</div><p>
<p><span class='label'>Langcode</span>: <div class='metadata' id='langcode'>en</div><p>
<p><span class='label'>Language</span>: <div class='metadata' id='language'>English</div><p>
<p><span class='label'>Lastupdate</span>: <div class='metadata list' id='lastupdate'><ul>
<li>Last Update Year/Month: 2023/02</li>
<li>Last Update: 2023/02/14</li>
</ul></div><p>
<p><span class='label'>Chapters</span>: <div class='metadata int' id='numChapters'>5</div><p>
<p><span class='label'>Words</span>: <div class='metadata' id='numWords'>17789</div><p>
<p><span class='label'>Python_Version</span>: <div class='metadata' id='python_version'>3.10.1 (main, Dec 23 2021, 12:15:59) [MSC v.1929 64 bit (AMD64)]</div><p>
<p><span class='label'>Rating</span>: <div class='metadata' id='rating'>Teen And Up Audiences</div><p>
<p><span class='label'>Story URL Section</span>: <div class='metadata' id='sectionUrl'>https://archiveofourown.org/works/44538691</div><p>
<p><span class='label'>Series</span>: <div class='metadata' id='series00HTML'></div><p>
<p><span class='label'>Additional Series</span>: <div class='metadata' id='series01HTML'></div><p>
<p><span class='label'>Additional Series</span>: <div class='metadata' id='series02HTML'></div><p>
<p><span class='label'>Additional Series</span>: <div class='metadata' id='series03HTML'></div><p>
<p><span class='label'>Publisher</span>: <div class='metadata' id='site'>archiveofourown.org</div><p>
<p><span class='label'>Site Abbrev</span>: <div class='metadata' id='siteabbrev'>ao3</div><p>
<p><span class='label'>Status</span>: <div class='metadata' id='status'>In-Progress</div><p>
<p><span class='label'>Story ID</span>: <div class='metadata' id='storyId'>44538691</div><p>
<p><span class='label'>Story URL</span>: <div class='metadata' id='storyUrl'>https://archiveofourown.org/works/44538691</div><p>
<p><span class='label'>Title</span>: <div class='metadata' id='title'>The Velvet LaChance</div><p>
<p><span class='label'>Titlehtml</span>: <div class='metadata' id='titleHTML'><a class='titlelink' href='https://archiveofourown.org/works/44538691'>The Velvet LaChance</a></div><p>
<p><span class='label'>Downloader Version</span>: <div class='metadata' id='version'>FanFicFare v4.20.0</div><p>
<p><span class='label'>Warnings</span>: <div class='metadata list' id='warnings'><ul>
<li>Graphic Depictions Of Violence</li>
</ul></div><p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)