package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_([^_]+)`)
var str = `ignore_firstMatch_match2_thirdMatch`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}