$re = '/(?=_([A-Za-z0-9]+))/';
$str = 'ignore_firstMatch_match2_thirdMatch';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);