import re
regex = re.compile(r"\b(?:loan)\s*(?:balance|amounts?|reimbursements?|installments?)?\s*(?:of|is|\s|\:|\-)\s*(?:(?:[\$]\s*[\.,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?)|(?:[\.\,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?\s*(?:dollars?|\$)?)|(?:[\.\,\d]+\s*(?:\$)))|(?: [\$]\s*[\.,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?)|(?:[\.\,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?\s*(?:dollars?|\$ ))|(?:[\.\,\d]+\s*(?:\$ ))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("loan balance is $45,56.89\n"
"loan balance of $ 1M\n"
"Loan Amount of 43000K\n"
"loan reimbursement is 54.4 dollars\n"
"loan reimbursement is 34,10.45 million\n"
"loan balance of 25000$ \n"
"loan amount $100,200.30\n"
"Loan Amount: 100K\n"
"Loan Amount $ 1.5 million \n"
"loan is $54K\n"
"loan balance - 50K$ \n"
"----------------------------------------------------------------\n"
"2.9 millions\n"
" $25000.50\n"
"1,99$ \n"
" $25000\n"
"1.10 dollar $25000\n"
"1,99 dollars $23K \n"
" $ 25,00\n"
"1.10 dollar $25,000.50\n"
"1,99 dollars $25000.50\n"
"10 dollar\n"
" $ 25,000\n"
"1.99$ \n"
"1,99$ \n"
" $25000\n"
"1.10 dollar $25000.50\n"
"1,99 dollars\n"
"10 dollar\n"
" $ 25,000\n"
"25,000.50$ \n"
"1.99$ \n"
" $25,000.50\n"
"1.10 dollar $25000.50\n"
"1,99 dollars $23K \n"
"10 dollar $25000\n"
"1.99$ \n"
" $ 25,000\n"
"djkb_09$kjh87\n"
"gh67_($67.67P)\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")