$re = '/[\d,]+(?=%)/m';
$str = '20MG/ML (2,5%)+0,5%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);