import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:YMS\\-(?:1[54]|07B)|M(?:S(?:M\\-(?:10|0(?:7S?|4F?|3))|N\\-(?:02|X2)|\\-(?:X1[60]|1(?:4[AS]?|1)|R09|0(?:6[FSJ]?|9R?|7B?|5B)))|A(?:N\\-(?:0[738]|X[38])|\\-0(?:5H?|4X|8)|X\\-03|M\\-07)))";
final String string = "MAM-07";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}