package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b((?:YMS\-(?:1[54]|07B)|M(?:S(?:M\-(?:10|0(?:7S?|4F?|3))|N\-(?:02|X2)|\-(?:X1[60]|1(?:4[AS]?|1)|R09|0(?:6[FSJ]?|9R?|7B?|5B)))|A(?:N\-(?:0[738]|X[38])|\-0(?:5H?|4X|8)|X\-03|M\-07))))\b`)
var str = `MAM-07
YMS-07B
YMS-07 -- 無効なモデル名に部分マッチしなくなった`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}