$re = '/^[^}{]*\{([^}{]+)\}[^}{]*$/m';
$str = '{amdnia91(+wowa}
{amdn{ia91(+wowa}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);