using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(CAN|NUL|E(?:TX|NQ|SC)|S(?:OH|UB))(?:(?!\1).)*";
string input = @"3NUL<123>lkjasdf lfdl;kja (432) adsfa sd 4ETX<342> sdfasdf asfds asdfa4(1 234)
4ETX<345> asdfasdf
NULSOH<342> sadfasd fasasdf asd 4ETX<345> asdfasdf ";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}