$re = '/^\+92[0-9]{10}$/';
$str = '+921234567899';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);