re = /^(?:(?:(?!cdefghijkl)c?[^c]*)++\Kcdefghijkl|(?:(?!bcd)b?[^b]*)++\Kbcd)/
str = 'abcdefghijklmnopqrstuvw'
# Print the match result
str.match(re) do |match|
puts match.to_s
end