$re = '/(^(\d{4})(\d{2})(\d{2})$)|(^(\d{2})(\d{2})(\d{2})$)/m';
$str = '20160531
160531';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;