package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\\(\w*K.TIF)$
`)
var str = `*.TIFF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}