using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2})(\d{2})(\d{2})";
string substitution = @"$3/$2/$1";
string input = @"140923";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}