import re
regex = re.compile(r"(?<=\s|\A)([^\s=]+)=(.*?)(?=(?:\s[^\s=]+=|$))")
test_str = "eventId=588622 app=HTTP in=5326 out=5326 categorySignificance=/Normal categoryBehavior=/Communicate/Query categoryDeviceGroup=/Application catdt=Web Cache categoryOutcome=/Success categoryObject=/Host/Application/Service art=1359127995713 cat=Access Log deviceSeverity=2 rt=1359127975000 src=1.1.1.1 sourceZoneURI=/All Zones/ArcSight System/Public Address Space Zones/US Department of Defense dst=208.85.40.20 destinationZoneURI=/All Zones/ArcSight System/Public Address Space Zones/ARIN/204.0.0.0-209.255.255.255 (ARIN) dpt=80 fileType=application/json; request=http://www.pandora.com/json/music/artist/justin-moore?explicit\\=false requestMethod=GET requestClientApplication=Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.142 Safari/535.19 cs2=false cs3=http://www.pandora.com/ cs5=Default cs1Label=Virus Name cs2Label=AV Enabled cs3Label=Referrer cs4Label=URL Category cs5Label=Policy cs6Label=Reputation ahost=ndeusemslvarc04.gold.rtgold.nima.mil agt=214.28.240.186 agentZoneURI=/All Zones/ArcSight System/Public Address Space Zones/US Department of Defense av=5.2.7.6474.0 atz=GMT aid=3DLoiRDsBABCAA9FvE1htRg\\=\\= at=syslog dvchost=xxx-xxx-xxx dtz=GMT _cefVer=0.1 ad.charset=utf-8"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")