$re = '/(?:Demandé par Dr :|\G)\s*\K(?:\S+)/';
$str = 'Demandé par Dr : NAME SURNAME';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);