#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)(?P<everything>" & @CRLF & _
"" & @CRLF & _
"(?:^|[\ \t\f!\"\#$%&'()*+,:;<=>?@\[\]^_`{|}~])(?!\/\/)[\w\.-]*?" & @CRLF & _
"" & @CRLF & _
"# URL path" & @CRLF & _
"(?P<subreddit>" & @CRLF & _
"# </r/subreddit>" & @CRLF & _
"(?:\/?(?<!\w)" & @CRLF & _
"r\/[\w-]+\b(?<!\/pcmasterrace))" & @CRLF & _
"|" & @CRLF & _
"# </tb>" & @CRLF & _
"(?:\/tb)" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"# </comments>/POSTID" & @CRLF & _
"(?P<comments>" & @CRLF & _
"(?:\/comments)?)??" & @CRLF & _
"" & @CRLF & _
"# Start the Post ID detection, and testing for whether or not it should match a shortlink" & @CRLF & _
"(?P<postID>\/\w{2,7}\b(?<!\/46ijrl)(?<!\/wiki))" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# Match rest of URL for debugging" & @CRLF & _
"[^\s\r\n\)]*" & @CRLF & _
")"
Local $sString = "DO NOT MATCH" & @CRLF & _
"](/fds " & @CRLF & _
"" & @CRLF & _
"[fdasf](/sw" & @CRLF & _
"fjsdalr/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"" & @CRLF & _
"MATCH" & @CRLF & _
"http://reddit.com/r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"np.reddit.com/r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"reddit.com/r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"/r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"" & @CRLF & _
"[r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"<r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
":/r/CHAN5/comments/2qjq7j/test_post/" & @CRLF & _
"" & @CRLF & _
"DO NOT MATCH" & @CRLF & _
"/2qjq7j" & @CRLF & _
"" & @CRLF & _
"MATCH" & @CRLF & _
"[Full link](http://reddit.com/r/CHAN5/comments/2qjq7j/test_post/)" & @CRLF & _
"[Full link](https://reddit.com/r/CHAN5/comments/2qjq7j/test_post/)" & @CRLF & _
"[Full with subdomain](//np.reddit.com/r/CHAN5/comments/2qjq7j/test_post/)" & @CRLF & _
"[Full with two-part subdomain](//np-dk.reddit.com/r/CHAN5/comments/2qjq7j/test_post/)" & @CRLF & _
"[Full without www](//reddit.com/r/CHAN5/comments/2qjq7j/test_post/)" & @CRLF & _
"[Without reddit.com](/r/CHAN5/comments/2qjq7j/test_post/)" & @CRLF & _
"[Without subreddit](/comments/2qjq7j)" & @CRLF & _
"[Ultrashortlink](/2qjq7j)" & @CRLF & _
"[Subreddit and post ID (no /comments)](/r/CHAN5/2qjq7j)" & @CRLF & _
"[Redd.it](//redd.it/2qjq7j)" & @CRLF & _
"[Reddit.com/tb](//reddit.com/tb/2qjq7j)" & @CRLF & _
"[Redd.it full link](//redd.it/r/CHAN5/comments/2qjq7j)" & @CRLF & _
"[subreddit without comments](/r/chan5/2qjq7j)" & @CRLF & _
"[weird other syntax](https://www.reddit.com/comments/3ovgmw/_/cw1h7jn)" & @CRLF & _
"[weird other syntax](https://www.reddit.com/comments/3ovgmw/)" & @CRLF & _
"[weird other syntax](https://www.reddit.com/comments/3ovgmw/ "test")" & @CRLF & _
"[weird other syntax](https://www.reddit.com/comments/3ovgmw?context=3)" & @CRLF & _
"[Ultrashortlink w/ alt text](/2qjq7j "fdsfa")" & @CRLF & _
"" & @CRLF & _
"[Deprecated toolbar link that still works for some reason](https://www.reddit.com/tb/1y70ej)" & @CRLF & _
"" & @CRLF & _
"https://www.reddit.com/r/SubredditSimulatorMeta/comments/4ksecc/the_anteaters_tongue_is_fully_extended_it_can_be/" & @CRLF & _
"DO NOT MATCH" & @CRLF & _
"[PCMR](https://reddit.com/r/pcmasterrace)" & @CRLF & _
"https://www.reddit.com/r/pcmasterrace/comments/4d9a43/campaign_to_bring_rock_band_4_to_pc_enters_its/" & @CRLF & _
"https://www.reddit.com/r/pcmasterrace/comments/4d9a43/campaign_to_bring_rock_band_4_to_pc_enters_its/d1owcop" & @CRLF & _
"https://www.reddit.com/r/pcmasterrace/comments/4d9a43/campaign_to_bring_rock_band_4_to_pc_enters_its/d1oz6if?context=10000" & @CRLF & _
"https://i.redd.it/vp2hsd4za4zw.jpg " & @CRLF & _
"[Image link](//i.redd.it/vp2hsd4za4zw.jpg)" & @CRLF & _
"https://www.reddit.com/gold/about/" & @CRLF & _
"https://www.reddit.com/r/SubredditSimulator/comments/4ksecc/the_anteaters_tongue_is_fully_extended_it_can_be/" & @CRLF & _
"" & @CRLF & _
"MATCH (not the first or the non-Reddit link)" & @CRLF & _
"If you're looking for more information about this campaign, here are some useful resources." & @CRLF & _
"" & @CRLF & _
"- [The Harmonix AMA in /r/PCMasterRace](https://www.reddit.com/r/pcmasterrace/comments/4cqxz9/we_are_harmonix_and_only_you_can_help_us_bring/) Tons of questions and answers here." & @CRLF & _
"- [A recent interview with HMXJosh that covers many of the questions asked in the AMA in different levels of detail](https://www.reddit.com/r/Rockband/comments/4co7ta/my_interview_with_josh_from_harmonix_about_rock/)" & @CRLF & _
"- [The original announcement thread in /r/RockBand](https://www.reddit.com/r/Rockband/comments/48heg7/rock_band_4_on_pc_gasp_crowdfunding_campaign_is/)" & @CRLF & _
"- [A really informative Update on the Fig page specifically abou tthe quality of the PC port](https://www.fig.co/campaigns/rock-band-4-pc?update=97#updates)" & @CRLF & _
"- [A collection of HMXJosh posts from the last few days](https://www.reddit.com/r/Rockband/comments/4cr3u3/wondering_about_exports_or_other_hot_topics_heres/)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"The biggest draw, in my opinion, is the return of the Rock Band Network. Basically this means user-generated content for sale, and (most likely) free customs as well. RBN on the Xbox 360 brought all kinds of lesser known artists and genres to the game and before long there were many people (myself included) who almost exclusively purchased DLC from there instead of the official store. RBN offered double bass charts for drummers, which is something we've never seen in official DLC either. So the prospect of getting this back is, for me, pretty huge." & @CRLF & _
"" & @CRLF & _
"On top of this, PC as a platform offers better peripheral support, more powerful graphics options, and an opportunity for a really efficient UI in places where controllers are sub-optimal (eg, searching your song list). "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")