package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^0[1-9]|[12][0-9]|3[01])-(0[1-9]|1[0-2])-(\d{4}$)`)
var str = `20-11-1000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}