package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(animal.*?lamina)|(lamina)`)
var str = `animal hello lamina
animal lamina
lamina
animal`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}