import re
regex = re.compile(r"^\d{3}-\d{2}-\d{4}$", flags=re.MULTILINE)
test_str = ("555-55-5555\n"
"11111111\n"
"111-111-1111\n"
"111-22-5555")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")