$re = '/(?![\'\,\.\?\!a-zA-Z]+)/';
$str = 'i\'m so happy that you\'re here with me! :)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;