package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]+"(*SKIP)(*FAIL)|,`)
var str = `Fruits,Pear,Cherry,Apple,Orange,"Cherry,"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}