$re = '/((\d+,)+\d+\.\d+)/';
$str = '$num = "R1,500.00 ZAR";
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);