$re = '/[#b]?(13|11|9|7|6)/';
$str = '#13';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);