using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(word1).*?(word2)?.*(word3)";
string input = @"word1word2 word3
word1 word3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}