package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?: # Start of group:
\b # Match start of a word
(?: # Start of inner group:
[A-Z][a-z]* # Either match an uppercase word
| # or
(?:a[nts]|the|by|for|i[nt]| # one of these "special" words
o[fnr]|to|up|and|but|nor)
) # End of inner group
\b # Match end of word
\s+ # Match one or more whitespace characters
)+ # Match one or more of the above.`)
var str = `Admit to Patient bla bla bla bla
Hello There bla bla bla bla
Get There by Noon bla bla bla bla
Get There By Noon please don't be late
Hello for Everyone on Here hope you are doing good
Hello For Everyone On Here hope you are doing good
Admit To Patient should be matched`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}