re = /.*\((?=\')|(?<=\')\)?,?\s?]?/
str = '[Nick(\'LeaderBot\'), \'d3rdwill\', \'Willie2\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end