$re = '/^[a-zA-Z0-9]+[._-]{0,1}[a-zA-Z0-9]+@([a-zA-Z0-9]+[._-]{0,1}[a-zA-Z0-9]+)+\.[a-zA-z]{2,}/';
$str = '"tim@apple.com"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);